Nikon site account issues?

ALThomasALThomas Posts: 6Member
edited November 2013 in General Discussions

I just want to make sure this isn't just on my end. I have been trying get a lens sent into Nikon support, but the account system on the Nikon website seems to be broken. I log in just fine but then when I try to access "Camera Bag", "Account", or "Support Questions" I just end up being directed to an error page.

"
https://support.nikonusa.com/app/error/error_id/saml18/subject/contact.id

Oops! Something happened...
It seems that an error occurred while you were trying to access that page: "Unknown Error"

Unknown error
"

I tried it on a couple of different computers to make sure it wasn't that, but it didn't make any difference. Anyone else getting this same kind of problem with the Nikon site?

Comments

  • Parke1953Parke1953 Posts: 455Member
    Works fine for me but it seems like they have made some changes. This is what I got when I opened my camera bag (Welcome to the all-new My Camera Bag). Looks like all my stuff is gone and have to start over.
  • Parke1953Parke1953 Posts: 455Member
    My mistake it's all there. Works fine for me ALThnmas.
  • ALThomasALThomas Posts: 6Member
    Oh that is extremely irritating. I wonder if its some kind of bug with my account with the way they upgraded the system. I wonder if you can re-input serial numbers if they are already attached to another account? Hmmm.
  • Parke1953Parke1953 Posts: 455Member
    Maybe you could try a reboot of your computer sometimes it makes things work better. Oh when I first logged on my password would not work so I had it reset. when I logged in and opened my camera bag and got to the page that said Welcome to the all-new My Camera Bag, looked around the page and clicked on one of the boxes below and it all came up. Hope this helps.
  • DustyNikonDustyNikon Posts: 1Member
    Yes, I had the same issue last week when I was sending in my camera to get repaired.

    I called and spoke to USA customer service which said they had changed their website and were aware of the problem. However, she couldn't say when it would be fixed. She was able to pull up my warranty info and said until the website works I would need to phone in anything I would have otherwise done online. (Kind of annoying since I'll just have to assume if the site doesn't work in the future that they're still working on it.)
  • ALThomasALThomas Posts: 6Member

    Hmm, seems that it doesn't effect everyone then. Very annoying... but thanks guys. I'll give them a call tomorrow so I can get my repairs going.
  • HipShotHipShot Posts: 473Member
    The site was wonky for me, too, last week while I was trying to register a lens. I ended up doing it over the phone. The operator mentioned that they were updating the site. Was back there yesterday for another matter and everything seemed fine.
  • MsmotoMsmoto Posts: 5,396Moderator
    edited November 2013
    I logged on and was required to reset my password, but all went just fine. It appears the site has been significantly modified, improved possibly.
    Post edited by Msmoto on
    Msmoto, mod
  • PhotobugPhotobug Posts: 4,603Member
    Same experience as Msmoto, when I logged into the site to register my new WiFi adapter I had to reset my password and all my purchase history was there.
    D750 & D7100 | 24-70 F2.8 G AF-S ED, 70-200 F2.8 AF VR, TC-14E III, TC-1.7EII, 35 F2 AF D, 50mm F1.8G, 105mm G AF-S VR | Backup & Wife's Gear: D5500 & Sony HX50V | 18-140 AF-S ED VR DX, 55-300 AF-S G VR DX |
    |SB-800, Amaran Halo LED Ring light | MB-D16 grip| Gitzo GT3541 + RRS BH-55LR, Gitzo GM2942 + Sirui L-10 | RRS gear | Lowepro, ThinkTank, & Hoodman gear | BosStrap | Vello Freewave Plus wireless Remote, Leica Lens Cleaning Cloth |
  • lbillslbills Posts: 1Member
    I have been having this same problem for days now. I get the same "Ooops" when trying to email support. Guess that cuts down on the number of complaints. I would think fixing a problem with a major part of your public facing business would be a priority. Frustrating.
  • scoobysmakscoobysmak Posts: 214Member
    Well I just tried to see what it would give me, I had updated my information about 6 months ago and believe that is roughly the time the site upgrade happened but not sure. Using Google Chrome when I first tried to login using the "My Account" drop down menu at the upper right, I logged in like normal but something weird happened. I clicked on "service and support" and then it said "My Name" could you please log in and showed me a login screen again????? Uh how did you know my name if I wasn't logged in?????? I then opened another browser on my computer and then hit "service and support" first, nothing happened????

    I went back to Google chrome and then went to the bottom of the screen and hit "service and support" there. The screen opened and then hit my camera bag and that worked as well, I did not have to log in again. I am in my camera bag but not the most efficient way to get there.
Sign In or Register to comment.